Rough Idle and Low RPM... I'm out of Ideas

Any help, ideas, or suggestions will be greatly appreciated. I've spent all the time I've had over the past couple of weeks trying to get this straight and I'm out of ideas.

Mods at the beginning:
LARS airbox mod
BMC Filter
Leo Vinci Slip-on



Chronological order of events:
1) Picked up a used Power Commander 3 and installed it. (it didn't come with the O2 sensor delete and I didn't know about it till later)
2) Ran fantastic, no issues at all, nice and smooth.
3) Decide to gut the cat.
4) Take the slip-on off preparing to gut the cat and decide to ride it without the slip-on and the cat still in it. Why? Because LOUD NOISES and I'm a little kid when it comes to stuff like this.
5) On this 1-2 mile ride with the cat, but no slip-on, it runs awful <5,000 rpm, but sounds glorious over 5k rpm. I assume the jumpy rpm down low is just due to minimal back-pressure.
6) Don't think anything of it and proceed with gutting the cat.
7) Put everything back together, gear up for a day of riding, and... still runs rough under 5k rpm.
8) After I throw a temper tantrum I get on the computer and find others who had the same issue and it was due to the O2 sensor. Perfect! Order the dummy plug for the harness and plug the exhaust.
9) Put everything back together and... still no change.
10) Try different PC maps, no map, turn the idle up, everything I can think of (which wasn't any more than what I listed) to no avail.

When I cold start the engine everything runs well, no issues at all really. It warms up and settles down and it just can't maintain RPM. From normal idle it will jump up 300-400 rpm, then go about 100-200 rpm under normal rpm, then straighten out before the cycle starts over. When riding at low speed it's the same way. It isn't safe to take a turn in gear with it jerking like this. It nearly bogs down when you get into the gas and once you get around 5,000 rpm it runs fine.

I don't know what my step is. The only thing I can think of is to flash the ECU, but I don't actually think that would fix this. It throws me off how it happened instantly when I ran the bike with no muffler installed.

I have read every potentially relevant thread I can find and can't find a solution.
 
Last edited:

Dicko

Active Member
What is your idle at? it should be around 1200 rpm.

Are you sure the O2 sensor delete is working/plugged in properly?

have you tried re-installing the firmware on the powercommander and then tried re-loading a map?

You may need to alter the air fuel ratio down low in the rpm range. Which maps have you tried? Do they differ substantially in the lower RPM range?
 
Before all this it was right on 1200. Since all of this I've had it up to 1,700 roughly. It's hard to tell because it will bounce all over the place.

It's just a cheap o2 delete off eBay. I don't know that's it's working correctly, but it just connects a couple of wires. It only installs one way, so I don't think that's it.

I have not tried to reload the firmware, I'll give that a shot next.

I've tried essentially every map in the map pack and none of them make it act any different at idle. I'll link a YouTube video shortly to show exactly how it is.

Sent from my SM-G920V using Tapatalk
 

Dicko

Active Member
OK, I watched the video and that is weird.

I re-read your original post. I didn't see that you had tried unplugging the Powercommander. Give that a go. electronics have a life span, and PCIII are getting on in years now. It may be on the way out. A PCV doesn't need an O2 eliminator, you can simply unplug it and get it tuned to run without it.

I'd try to get back as close to stock as possible to see if that resolves the issue, change 1 thing at a time to make sure you figure out what is causing it.

The other thing to check is if you need to change a setting in the PCIII to let it know there is no O2 sensor - I don't have my laptop with me so I can't check the settings for this.
 
I am not sure how old the PC3 is, I just bought it on here a couple of months ago. Everything was working perfectly before I ran it without the slipon. When I get home from work today I'll update the PC firmware (which I haven't done since I bought it). If that doesn't do anything I'll disconnect it altogether. It looks like if that does correct the issue then I have two options: buy a PCV or pick up a set of factory headers with the cat.

Any ideas if this doesn't take care of it? I want to try as many things as I can when I get home. My bike has been down for various reasons lately and my dirt bike is out momentarily as well. Needless to say I'm having withdraws and I need to get my fix soon.
 

cookie

New Member
Yeh what dicko said, get it back to stock and see what happens. I wouldn't bother getting factory headers for the cat, removing the cat wouldn't cause this. Take the pc3 out and see what it does. Sounds like something electrical or a sensor maybe? But not cat removal. Also try unplug the battery for 10 mins to reset the ecu.
 
I just really threw me for a loop because I rode it for 8 hours the day before and everything was great. Then just take the slip-on off and BAM, problems. I'm thinking (and somewhat hoping) it isn't a sensor, just because it was so instant and only after I changed something. I have my fingers crossed one of these suggestions will clear it up. I disconnected the battery for a couple of minutes and tried to start it (just to clear out any electricity in the wires), that didn't do anything. I didn't realize it may take that long to reset the ECU. Thank you for suggesting it, i'll try that as well.

If resetting the ECU clears it up I will be ecstatic! Even if it's the PC I will still be happy. I'm to the point I just want to know what the hell it is so I can start riding again. I don't even care if it is 27 degrees and there is snow on the ground.
 
Forgot to bring my computer gone to reset the firmware on the PC.
Doesn't seem that's it though. I left the battery disconnected for 20+ minutes, still ran rough after.
Disconnected the PC and still ran just as rough.
What do y'all think about the possibility of the valves needing to be adjusted? I am just over 26k miles...

Sent from my SM-G920V using Tapatalk
 

Dustin

Moderator
It all seems so sudden and strange that it's hard to imagine it could be a major mechanical item like valves. It's got to be software or electrical related.
 
Any update mate? Had any luck?
I haven't had much time to work on it the past couple of days. Since I don't have a clear idea of what could be causing this, I will check to make sure every cylinder is firing, change spark plugs, check the TPS, and have the valves adjusted. If none of that works I may send the ECU to Ivan to have it flashed.

Any other ideas on things to try?
 

Mumbo

New Member
Well I watched the video and if I forget all the information about oxygen sensors and power commanders I'd say you've got a classic case of FZ1 ignition coil dying.

Looks exactly the same as mine was when No. 1 coil was on its way out.

Keep us updated these threads are useful for others with the same symptoms.
 
Hopefully I'll find out this week. I took it to a local shop that does great work. Should be getting into it today. I'll keep everyone updated. Fingers crossed for a quick and cheap fix so I can do some other stuff as well.

Sent from my SM-G920V using Tapatalk
 
Top